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onverting old libraries

To convert your 1.0 libraries, double-click the Converter application. ( available only to 
registered users)

Setting memory requirements

Memory requirements have been set at 700k,    If you need to open many libraries at the same 
time, increase the requirements to 1000k by first selecting the MacLibrarian application and then
selecting the Get Info menu item from the File menu in the Finder.

Creating a new Library

To create a new Library document:

1.    Select New from the File menu.

2.    Enter the name of the document in the dialog.

3.    Click the Save button.

Building a library

You can build a library by using Fast Scan or Scan Disk.    Fast Scan is limited to the internal 
drive.    

To build a library using Fast Scan:
1.    Select Fast Scan from the Librarian menu.

2    Insert the disk to be scanned.

3.    Repeat step 2 for all the disks to be scanned.

4.    Click Done.



To build a library using Scan Disk:

1.    Select Scan Disk from the Librarian menu.

2.    Select the desired drive from the Disk pop-up menu in the dialog.

3.    Click the Scan button.

Identifying a disk

You can obtain the following information on a previously stamped disk:    the disk name, serial 
number, date created, date modified,    date stamped and the name of the library that the disk 
belongs to.

To obtain the disk information on a previously stamped disk.    

1.    Select Identify Disk from the Librarian menu.

2.    Insert the disk to be identified in the drive.    
            (If a disk is already present in the drive, the eject button is enabled to 
            permit you to eject that disk.)

3.    Click the Cancel button to exit the dialog.

Opening a library file

You can have more than one library file open at a time.

To open a library file:

Double-click on the desired library file.

or
1.    Select the Open menu item from the File menu.

2.    Select the desired library file from the dialog.

3.    Click the Open button.

Closing a library file

Closing the disk window will close all open windows associated with that library.



Saving a library file

You can save the changes to the working library file or to a new file.

To save changes to the library file:

Select Save from the File menu.

To save changes to a new library file:

1.    Select Save As from the File menu.

2.    Select the desired drive and directory from the dialog.

3.    Type the new name of the library file.

Quitting MacLibrarian

To end your working session:

1.    Select Quit from the File menu.

2.    If you have made changes to the Library file since your last save, 
          you will be presented with a dialog, do one of the following:

              Click Yes to save the changes to the file and quit.
              Click No to ignore all the changes and quit.
              Click Cancel to cancel your request to quit.

Deleting records

There are several way to delete a disk record.    You can use Cut, Clear or Delete Disk in 
conjunction with the Tidy menu item and with Auto Tidy disabled or you can use Cut, Clear, 
Delete Disk with Auto Tidy enabled.    If Auto Tidy is disabled, the disk is merely marked for 
deletion (it appears dimmed) until the Tidy menu item is used.    If Auto Tidy is enabled the 
records are deleted immediately and cannot be retrieved.    You can mark many disk records for 
deletion and then use Tidy to delete them in a single pass.    

You can only delete disk records.

The Auto Tidy is enabled or disabled by selecting Auto Tidy from the Preferences menu.

To delete a disk record using Delete Disk:



1.    Select Delete Disk from the Librarian menu.

2.    Enter the disk number (serial number) of the disk to be removed in the dialog.

3.    Select the OK button.
          The disk to be deleted is dimmed.

4.    Select Tidy from the Librarian menu.
           The disk and all other dimmed disks are removed from the library.

To delete a disk record using Cut or Clear:

1.    Select the disk record or file record by clicking on it.

2.    Select Cut or Clear from the File menu.
          The disk to be deleted is dimmed.

3.    Select Tidy from the Librarian menu.
          The dimmed disk and all other dimmed disks are permanently removed 
          from the library.

Copying records

To copy a record:
First select the record, then use the Copy menu item from the Edit menu.    The record is copied 
to the Clipboard.

All records are copied as text tab-delimited and can be transferred to other word processing 
packages.

Pasting from the Clipboard

To paste information from the clipboard into the search area:
Select the text in the Search Area and then select Paste from the Edit menu.

Moving columns

You can rearrange the order of the columns:

1.    Click and hold down the mouse button on the column (view) title of the 
          column you wish to move.
          The cursor changes.



2.    Move the cursor while still holding down the mouse button to the new 
          position (in the new title area) and release the mouse button.
          The new column is inserted to the left of the place where the mouse 
          button was released.

Adjusting column widths

To adjust the width of a column: 
Select the column divider line in the view area and move it to the desired position.    Your cursor 
changes to a vertical bar with horizontal arrows indicating that you can change the column 
widths.    

 

iding columns

To hide a column:
 Drag the right column divider line of the column you wish to hide and place it over the left 
column divider line.    A hidden column is indicated by a thick divider line in the view title area.   
(This feature is similar to the one in Excel).

 

hanging the title of a column

To change the column title:
Double-click in the column title area.    You will be presented with a dialog box that lets you 
change the title and hide the column if desired.

 



aking hidden columns visible

To make a hidden column visible:
Select the thick divider line in the view title area and drag it to the right.    This will expand all 
columns that are hidden at that position.

Displaying disk contents in tree format

To display the contents of a disk in tree format:
Double-click on the disk or file record.

 

hanging the size of the tree

You can change the default icon size and the default vertical and horizontal spacing between the 
icons:



1.    Select Display from the Preferences menu.

2.    Click in the check boxes of the resulting dialog.    
          This disables the check boxes and activates the editable fields.

3.    Edit the fields as required.    (The sizes are in pixels.)

4..    Click the OK button.

Displaying folders in the tree

The plus (+) icon that appears on the folders in the tree is used to indicate a folder that can be 
expanded.    The minus (-) icon is used to indicate a folder that has been expanded and can now 
be collapsed.

Double-clicking on a folder with a plus icon expands the folder; that is, it displays the next level 
in the tree hierarchy.    If you want to expand the entire folder and any folder within (that is, the 
entire tree hierarchy of the folder) then hold down the Command key and double-click the folder.

To collapse a folder with a minus icon:Double-click the minus folder and hold down the 
Command key. 

To hide the contents of the folder:
Double-click on the folder.    Collapsing a folder removes the contents of the folder from the tree 
hierarchy.    

If you double-click on a collapsed folder you get only next level in the tree hierarchy.    If you 
double-click on a folder in which you hid the contents, the entire hierarchy that was previously 
displayed is made visible.    

Displaying archive files in the tree

Archives files are treated like folders with one exception: if the    Expand Archive preference is 
enabled then the archive file is shown expanded to the first level.    All folders within the archive 
are treated as normal folders.

To get the archive to behave like a normal folder, disable the Expand Archive preference.

Displaying file information in the tree

To display information about a file or folder:
Click on the file or folder.    The information is displayed on the left side of the window.



If the information is not fully visible, move the pointer to the right edge of the tool area, then 
click on the edge and drag the edge to the right to expand the information display area.

Sorting

You can sort on any field of the records in the disk or file library providing the appropriate 
window is active.    You can also use the view title in conjunction with the AutoSort preference.

To sort using the menu command:
1.    Select the desired window.

2.    Select the Sort menu item from the Librarian menu.

3.    Select the type of Sort you wish to perform from the resulting pop-up menu.

To sort using the view titles:
1.    Enable Auto Sort from the Preferences menu.

2.    Click and hold the mouse button on the view title you wish to have sorted.

3.    Drag the view title to the first column and release the mouse button.

Searching

There are two ways to search for information.    You can use the Find menu item or you can use 
the search area.

To find using the menu command:

1. Select the window for which the search is desired.

2.    Select the Find menu item from the Librarian menu.

3.    Enter the search string in the text field.

4. Click the Find button.

The search area at the bottom-left corner of the windows can be used to search for text.    The 
first column must be sorted if you are using the search area.

To find using the search area:
1.    Sort the column you wish to search in.    It must be sorted and the first column. 



2.    Type the item you wish to sort for in the search area.
          The search commences and the screen scrolls as you type in each letter.

Setting Preferences

Use the Preferences menu to set the following preferences:

Auto Sort—when enabled a sort is automatically done on column items when the column is 
moved to become the first column.    If disabled the items in the column are not sorted.

Auto Tidy—when enabled disk records are removed permanently from the library without being 
first dimmed or marked for deletion.    If disabled the disk records are first dimmed and you then 
have to use the Tidy menu item to remove them from the library.

Fast Scan—when enabled MacLibrarian limits the scan to the internal floppy drive If disabled 
you can scan other drives such as optical drives, CDs and hard disks.    Fast Scan enabled is the 
default.

Expand Archives—performs two functions:

1.    when enabled archive files is expanded to the first level when displayed in the tree window.   
If disabled the archives are treated as normal folders.

2.    Will read the contents of StuffIt and compactor archives when enabled.

Stamp Disk—when enabled the disk is stamped: an invisible file, which can be used to recall the 
serial number of the disk, is written to the disk.    Stamp Disk disabled is the default.

Ask Before Delete—When Auto Tidy is enabled, a record can be permaently deleted.    However,
you are given a warning before the record is deleted if Ask Before delete is enabled.    If you 
don't want the warning disable Ask Before Delete.

Display—is used to change the size of the icons and spacing in the tree window.

Filter—is used to define filters to be applied to all windows and printing operations.

Printing the disk or file library

To print the disk or file library:

1.    Select the disk or file window.

2.    Select the Page Setup menu item from the File menu and set your margins.    
          If you want to print only selected items check the Print Hilites Only check box.



3. Select Print from the File menu.

4.    Click OK to start printing.
          You can stop printing at any time by pressing the command key and typing a period.

Printing a tree

1.    Select the tree window.

2.    Select the Page Setup menu item from the File menu and set your margins.

3. Select Print from the File menu.

4.    Click OK to start printing.
          You can stop printing at any time by pressing the 
          command key and typing a period.

Exporting

You can export your data to file.    You can Export either all the data associated with a window or 
just parts of it.    All data is exported tab-delimited.

To export data to a file"

1. Select the Export menu item from the File menu.

 

.    You can do one of the following in the resulting dialog:
          Select the Export Hilited Items Only check box to export hilighted items
          Select the Export Visible Items Only check box to export visible items
          Select neither of the above check boxes to export the entire contents of the window.



Labelling your disks

To label your disks:

1.    Select the disk records of the disks you want to label from the disk window.

2.      Select the Labels menu item in the File menu of the disk window.

You can now use the resulting dialog to create a new label template or to load a predefined 
template.

 

reating a label template

Use the Labels dialog to define the label width and height, the vertical and horizontal spacing 
between labels, the number of labels across and down a page, and the page margins.    You can 
use the editable text fields or the graphical representation of the label page to define these values.
Selecting any solid line other than the border lets you graphically change any of the label page 
formats (the exception is the the number of labels across).    

To define the graphics you want included in the label:

Click on the icon at the top of the tool area. The Labels dialog changes and you are provided 
with a tool palette 
You create objects using the tool palette, MacDraw style. The tools in the tool palette are similar 



to those available with other drawing packages with the following exceptions: the pict tool and 
the file tool.

 

he pict tool lets you define an area on the label to paste a picture from another application.    It 
will rescale the vertical and horizontal size of the picture to fit in the enclosed rectangle.

The file tool lets you define an area on the label in which to print a column of the    names of the 
contents of your disk.    Note only the top-level names of the contents are printed.    If your names
spill over the columns, you can define a second area (or as many that will fit) beside the first.    
You can define more than one file object on the label.    MacLibrarian keep tracks of the 
filenames already printed and continues from where it left off on the first column.    This is useful
if you want to print two or more columns of filenames on your label.

Putting disk information on a label

You can include disk information from your library on your label by selecting the desired item 
from the table at the top of the second view (for example, Num, Stamped) and dragging it 
anywhere on the label.    When you print the label the value of the view item is substituted.

 



nce you have dragged a view item to the label, you don't have to delete it and drag another item 
if you want to change it.    You can double-click and select another view item from the pop-up 
menu associated with the view item.

 

dding attributes to label objects

To change the attributes to an object.
1.      Double-click the object.    
            You will be presented with a dialog.    
2.      Use the dialog to change the attributes of the object.    
            You can change the following attributes: the background pattern of the object, 



            the position of the object, the font, the font size and style (if applicable), 
            and the pen size for the border of the object (if applicable)      

Deleting label objects

To delete an object select it and press the delete key on your keyboard.

Moving label objects

Select the object and use your Up and Down arrows on your keyboard to move the object to the 
foreground and background respectively 


